Messwerte sind verzögert

Guten Morgen,

ich habe das Gefühl, das seit ca. 1 Woche die Messwerte nicht mehr annähernd Realtime über die API kommen, sondern inzwischen ca. 50 Sekunden verzögert.

Ich habe im ioBroker eine Kontrolle eingebaut (wegen der ganzen Ausfälle in den letzten Monaten), das meine Scripte nicht auf „alte“ Werte reagieren, sondern eben nur auf zeitnahe Werte. Das lief eigentlich mit 10 Sekunden als Grenzwert zwischen „funktioniert“ oder „stolpert“ ganz gut, das habe ich vor vielleicht einer Woche auf 15 Sekunden angehoben, weil es dann 11 Sekunden waren, und inzwischen wird mir ~50 sek Delay angezeigt. Der Adapter in ioBroker steht auf alle 5 Sekunden aktualisieren.
Ich weiß nicht, ob die Uhr im Zähler selbst „falsch tickt“, oder ob die Verarbeitung der Messwerte inzwischen so lange dauert, bis diese über die API ausgeliefert werden. Meine Rechner im Netzwerk sollten eigentlich über einen NTP-Server auf meinem Router gegen pool.ntp.org syncronisiert sein.
Momentan bin ich aber seit einigen Tagen unterwegs und kann nicht wirklich schauen, wie lange es dauert, bis das Einschalten eines Großverbrauchers z.B. in der App oder im Browser sichtbar wird.

Christian

Ich nutze auch die API über iobroker, ich kann keine Verzögerung feststellen, ich mache sekündliche Abfrage und kriege zeitnah ungefähr alle 2 Sekunden einen Wert geliefert und bei Verzögerung von mehr als 30 Sek würde ich auch eine Meldung im Log haben

Hallo Christian (@Familienvater),

ich habe mir Ihren Zähler im System angesehen, und tatsächlich gibt es eine Abweichung zwischen dem Empfang und der Verarbeitung der Messwerte auf dem Server. Ich werde Ihr Anliegen an unsere IT-Abteilung weiterleiten, damit die Kollegen die Ursache gründlich untersuchen können. Aufgrund der hohen Arbeitsbelastung der Kollegen kann ich jedoch nicht genau sagen, wann Sie mit einer Rückmeldung rechnen dürfen.

Viele Grüße
Pablo Santiago, Discovergy GmbH

Danke @PabloSantiagoDGY fürs kümmern.
Dann hoffe ich mal, das es zeitnah eine Klärung/Lösung für das Problem gibt.

Inzwischen bin ich zu Hause, und habe gerade mal getestet, auf dem Dashboard kommt die Spitze von einem zugeschalteten „Großverbraucher“ mit wenigen Sekunden Verzögerung, im ioBroker auch, nur der Zeitstempel, den die API für den Messwert mitliefert, scheint um die ca. 50 Sekunden in der Vergangenheit zu liegen.
Gegenüber der Web-Ptb-Uhr https://uhr.ptb.de/ gehen meine internen Uhren meiner Systeme „genau“ und haben nicht die Syncronisierung verloren.

Wir hatten jetzt am Montag 05.02.2024 gegen 12:30 einen 5 min Stromausfall in der Straße/im Ort (keine Ahnung ich war nicht zu Hause), meine ganze IT+Netzwerk hängt an einer USV, und auch die Internetverbindung während dem Stromausfall war stabil (der VDSL-Outdoor-DSLAM scheint auch eine USV zu haben, yeah!), vor dem Stromausfall war die API ca. 13 Sekunden hinten dran, kurz nach dem Stromausfall hat es sich dann bei ca. 49 Sekunden eingependelt. Ich gehe aktuell davon aus, das die interne Uhr im Zähler „falsch tickt“.
Kann ich das grüne Gateway durch einen langen Druck auf die Reset-Taste so „hart“ durchstarten, um eine neue Zeitsyncronisierung gegen Ihre Server zu starten?
Oder können sie ein Magic-Packet in einer Antwort an den Zähler mitschicken, das er sich bitte eine neue Zeit holen soll?

Christian

Ja, versuchen Sie es bitte. Gut möglich, dass das das Problem löst.

Hallo @PabloSantiagoDGY,

die Kollegen haben evtl. wegen der Nachfrage heute Vormittag was „umgestellt“, und ich habe das Gefühl, das Gateway sammelt jetzt immer die Daten einer Minute, und überträgt die dann als Block, das ist eine Vollkatastrophe. Reset hat nichts gebracht, der Zeitstempel schwankt jetzt zwischen ca. 60 und 120 Sekunden, das hat gar nichts mehr mit „Near-Realtime“ zu tun.

Anbei der Cacti-Graph vom Switchport, an dem der Zähler hängt,
graph_image
Es ist auf jeden Fall „Datensparsamer“, aber dann bitte wieder die alten Einstellung, ohne Werte-Sammeln…

Danke,
Christian

Hallo @Familienvater,

ich habe Ihre Bitte an unseren Support weitergeleitet.

Viele Grüße und schon einmal ein schönes Wochenende
Pablo Santiago

API ist wieder tot .

Mahlzeit @Andreas ,

nö, kann ich für meinen Zähler nicht bestätigen, es ist nach wie vor „Sägezahn“, das die Werte zwischen ~60 Sekunden alt sind, und sich dann das alter des Wertes auf ~120 Sekunden hochkämpft, und dann kommt wieder ein aktueller Wert, bis dann 60 Sekunden später der nächste aktuelle Werte reintröpfelt, weil der Zähler wahrscheinlich nach wie vor nur alle 60 Sekunden ein Block mit allen Werten überträgt.

Christian

Bei mir lässt sich nichts mehr über die API abrufen. Nutze HomeAssistant, aber vielleicht hängt das ja mit dem Umzug zu inexogy zusammen. Neuer Name neues Glück ? :smiley:

Update: Geht wieder